I built a new computer and installed Vegas Pro 13 and Swoopware to it. I used vegas 13 on my old computer as well. I successfully transferred over all my settings and templates using your instructions and everything is working but I am getting the "Some of the media on the timeline was not trimmed in order to preserve quality" alert box again and it doesn't get automatically clicked by swoopware like it did before. So far everything else is working great but I have to manually hit ok on this alert box. The box is at the top but it doesn't seemed like it is highlighted so I'm thinking when swoopware gives the signal to hit the ok button it doesn't actually do it because that box is not highlighted. Need to know what to do so I don't have to wait at my computer for the box to show up and manually click it.

Mick Hardy
Hi Iguard8,

You're the second person to report this issue but I can't reproduce it. The other computer was set to Danish and I thought it may have been a keyboard or language issue.

Can you let me know the build versions of Windows, TandemVids and Vegas 13 you have?

I haven't changed anything in that area recently but there must be a common cause for the keystroke to be lost. It's possibly a speed issue so the key stroke is sent before the window fully appears. Do you hear a sound as if the incorrect key was pressed? When the window appears, does it have focus already so you can simply press enter to clear it or do you have to select the window first?


Windows: Windows Key + R, and type winver.
TandemVids: Help | About
Vegas: Help | About Vegas Pro
Hi Mick, Here are my versions of everything.

Windows 10: version 1607 OS build 14393.693

Vegas 13: Build 545

Tandem vids: 2016.0.1.0

There is a sound,it is the "system Notification" sound. The window is not in focus. Just hitting return doesn't work. You have to select the window first or hit ok with the mouse. Sometimes it appears the box shows up goes away and then comes right back a second time. Other times it only shows up once but either way it has to be manually selected and clicked by me to go away. I attached a short video of both ways.

  swoopware issue.wmv (2,639kb) downloaded 91 time(s).

Thank you,
Mick Hardy
Thanks for the details and the video. You have all the latest software, exactly the same as my machine, which does clear the message.

Something on your computer is blocking or using the keystroke or stealing the focus.

I wonder if maybe another different message is being cleared by my keystroke and then the problem message is being displayed after the first message has been cleared. That's what the second video appears to do. Try resetting Vegas back to defaults. Options | Preferences | Default all.

I'll have to have a think about it over the weekend and see if I can reproduce it on my Notebook.
I tried resetting Vegas back to defaults but that didn't help. Hope you can figure it out.

This issue is getting really annoying! It messed me up a few times as I forgot to wait to manually clear the message then didn't have the video ready before having to get on next load. I have tried researching everything I could about having the window in focus but can't find anything to help. I have uninstalled and reinstalled both Vegas and Swoopware hoping it might fix it but it has not. Not sure what else to do but need to find someway to fix this soon.
Mick Hardy
I thought it may have been due to archiving to multiple locations but this also works fine for me. I configured two instances, each archiving to five different locations along with local projects and all twelve expected media trimmed message box alerts were cleared automatically and processing continued uninterrupted.

Can you try archiving manually and see if you get multiple message alerts?

  1. In TandemVids, enable test mode on the Test tab.
  2. Process a customer and wait until Vegas opens.
  3. In Vegas, File : Save As.
  4. Tick the box to copy media with project.
  5. Select "Create trimmed copies of source media."

Do you see multiple message boxes or any with different messages?

The code to force that message box in front of all other Windows so it receives the enter key is quite low level and fairly complicated. It uses direct calls into the Windows operating system. I bypass the .Net management code. Nothing you can do should change the underlying behaviour of how Windows work. A Windows update in the future may break my code but all the current updates behave as expected on all of my computers and also on various virtual machines I use for testing.

Do you have any software running in the background that may intercept key strokes or monitor window behaviour? Have you tried disabling your security software?

Vegas save as.jpg Copy media options.jpg Trimmed media alert.jpg
I tried this and only the one message box pops up that says "Some of the media was not trimmed..." and in this case it is in focus so just hitting enter clears it. Tried it again not in test mode and when that box pops up it was not in focus and so was not cleared again. I have done it with no other software running in the background, at least that I'm aware of. I also tried it with my McAfee security software disabled and it still didn't work.
Mick Hardy
I'm really stumped with this issue. I've had a good look at the code and can't see anything that could be tripping it up. It could be a timing issue because there is no built in delay. I focus the message and clear it without waiting. I'll add a pause in the next release using the same user configurable options I use for delaying DVD Architect key strokes.

I don't think jumping on your computer will help. I'll just see it happening the same as you.

Does it stop at the message box every single time or is it intermittent?

I think I'll build a small separate test application with the same code and see if you can clear the message after TandemVids fails to clear it.
It happens every time. No other programs lose focus at any time so it doesn't seem like there is another program stealing focus, that alert box just pops up and is never in focus.
Mick Hardy
I've built a little test application but I think I found the problem while building it. When I send the key to the window, it searches for the name of the message box, which is "Vegas Pro 13.0". A partial match currently returns true so the main Vegas window, which contains this text in it's title, may trigger the partial match. This means the key stroke would be sent to the main Vegas Window rather than the message box.

I've attached the application as promised if you wish to test it for yourself. The "Send (old)" button uses existing code with a partial name match. The "Send (new)" button has been fixed to ensure the full name of the window is matched.

  1. In TandemVids, enable test mode on the Test tab.
  2. Process a customer and wait until Vegas opens.
  3. In Vegas, File : Save As.
  4. Tick the box to copy media with project.
  5. Select "Create trimmed copies of source media."
  6. This should display the trimmed media message box
  7. Switch to the test application using default parameters
  8. Either send button should clear the message
  9. The "Send (new)" button should always clear the message
  10. After the message has been cleared, the "Send (old)" button will send a key to the main Vegas window
  11. The "Send (new)" button will display a window not found message

Stand by for a new release with this fix implemented.

Cheers. Mick.

  SendKeyToWindow.zip (97kb) downloaded 107 time(s).
I just saw this notice as I'm not getting notices to this topic for some reason even though I checked to watch this topic and receive notifications.

Anyway, I'm not sure if I'm doing it right or not but I did what you said. Enabled test mode and got the the point where the trimmed media message box shows up. I opened your sendkeytowindow application and clicked defaults then clicked the "send old" and the "send new" button. Neither one of them cleared the message, they both just said "window can not be found." I cleared the message manually and then tried both buttons again. They both still said "Window can not be found." Let me know if I should try something different. I will check this topic daily to make sure I don't miss a message from you.

Thank you,

Mick Hardy
Hi Luke,

To enable email notifications on the forum, select My profile | Email Notification Preferences and turn on "Notification for topics or forums you've selectively watched (listed below)". It's a new feature of the forum and appears to be turned off by default, which caught me out initially too.

It sounds like you're doing things correctly but I haven't solved the problem for you.

The partial match issue is definitely a bug but never really explained why it worked for me but not you. I've fixed this in TandemVids now but the next release is a long way off as I'm working on supporting the Magix version of Vegas.

I'll use the new TandemVids code in a new release of the test application and see if it resolves it for you. I'll add some debug options too.

Mick Hardy
Try this version of the test application.

Follow the same procedure to display the media trim message.

The application lists all window titles after it enumerates them searching for either a complete match or a partial match. If it isn't successful at finding the window, look through the list of windows and see if it's actually listed.

  SendKeyToWindow.zip (142kb) downloaded 86 time(s).
Mick Hardy
I've worked it out!!!!

I had another look at your video of the issue and noticed your media trim window is titled "VEGAS Pro 13.0" whereas mine is titled "Vegas Pro 13.0". The search is case sensitive so your window is never found.

Try changing the text for Window name in the test application to "VEGAS Pro 13.0".

Why is the real question here. Why does your version of Vegas have capitalised message boxes?

Mick Hardy
The only place that string is defined is inside the main executable for Sony Vegas Pro 13.0. I manually changed it to "VEGAS Pro 13.0" and the message box in question also reflected the change and was displayed capitalised.

My build was 453. You specified your version as 545. Please accept my apologies. I thought I had the latest version and glossed over your reply from memory without double checking build numbers.

I've just downloaded the Magix packaged version 13 build 545 and this issue has been replicated. They've capitalised "VEGAS Pro 13.0" in build 545.

You can see this on the Splash screen as well as in the message box title.

Thanks for your patience Luke.

Unfortunately that string is hard coded in the current version of TandemVids. I'll update this page when I work out what to do but I'm right in the middle of code changes to support the Magix V14 changes and can't easily release a quick fix.

My suggestion for the interim is roll back to a previous release like Vegas 13.0 Build 453 .

Vegas Pro 13.0 Build 453 Not Capitalised.jpg Vegas Pro 13.0 Build 545 Capitalised.jpg
Mick Hardy
A quote from Nick, one of the moderators over at the Magix Vegas Pro forum...

"VP13 builds 543 and 545 from Magix are just re-brands of Sony build 453. There is no new or improved functionality and it actually loses compatibility with some plugins and scripts. So in my opinion it's best to stick with 453 in most cases."
THANK YOU! I didn't even try changing the text in the test application and just downloaded and installed build 453. I did one test run and it worked so here's hoping the problem is fixed for now. Also thanks for including the links to find Vegas build 453. It was hard enough to just download Vegas 13 from the Magix site as every time I clicked on download under my software it brought me to the Vegas 14 sales page.

Thanks again!