Mick Hardy
I'm receiving a few reports of Vegas crashing at the end of the rendering stage, usually during the AC3 audio render. It appears to affect GoPro footage only. Some customers work fine but others fail. For the ones that fail, the render will fail conistently even without TandemVids running.

If anyone else is seeing this, please reply with the version of Vegas, the version of Windows and any other details you feel are relevant. I'll try and determine a common link.

I'm yet to see the issue despite hours of testing and continuous render loops using GoPro footage. This makes it extremely hard to trouble shoot but there are enough of you with the same problem to indicate it is a very real issue and I'll do my best to find a solution.

I'll update this thread with any news or progress on a resolution.
Mick Hardy
I have managed to reproduce this issue but I'm no further with a solution.

I processed a hundred AC3 renders in a loop and created twenty new videos using 100% GoPro footage for the source media without a single Vegas crash.

A suggested workaround to fix the problem is to ensure the last clip in the template is not GoPro footage. I realised all my test templates have some CX110 footage at the end.

After hearing about the workaround, I created a very simple project with four GoPro events and one music track and bingo, crashes nearly every time when rendering to AC3. This is completely outside TandemVids using Vegas Pro on its own. The project crashes in all 64 bit versions of Vegas including 9.0e, 10.0e, and 11 (Build 424).
Mick Hardy attached the following image(s):
Mick Hardy
I'm pretty sure I have a simple effective workaround for this GoPro issue.

You need to combine the audio into the video file and then rendering appears to work fine. The crash only occurs when you render the audio to a separate AC3 file.

1. You need to create a customised rendering template. Open Vegas, insert a video track and select "render as" from the file menu.
2. Choose MainConcept MPEG-2 and DVD Architect Widescreen (PAL or NTSC) and click Custom.
3. Select the Audio tab, tick the option to include audio, give your template a name and click Save.
4. Close all the dialogs and exit Vegas.
5. Delete DVD.AC3 from D:\Swoopware\TandemVids\Instance 01
6. Open TandemVids, select your customised template and the option to skip rendering the audio.
7. Generate the black video from the Test tab. Ignore the failed message. It's wrong and caused by the lack of an audio file.
8. Remove the security from your DVD Architect template.
9. Open your DVD Architect template and replace the current DVD.mpg file with the black one we just created.
10. Save the template, and write protect it again.

This should eliminate the render crashes caused by exporting AC3 audio from GoPro footage.

I'll keep searching for a real solution but this should help most people out.
Mick Hardy attached the following image(s):
Mick Hardy
Just a quick update on this issue.

A completely new installation of Windows 7 64 bit (Service Pack 1) and Vegas 9.0e (64 bit) on a virtual box has resulted in a working system. My test template rendered 50 times without crashing. A helpful person on the Sony Support Forum also had no problem rendering my test project.

The virtual box is installed on the same hardware as the system that consistently crashes. This means there must be a software conflict.

I'll start comparing running sofware, versions, libraries and configurations of the two systems and see if I can break my virtual machine.


We have been trying to resolve this for over year, without much success.

However! We seem to have fluked a solution on our systems.

When TandemVids begins creating the project it tends to crash saying "Low memory...", but if we click Ok it will continue to attempt to burn. Only then then the error says DVD.AC3 cannot be found.

So yesterday we tried changing the audio format to MP3, as a punt, and it's worked!

We have managed to burn a DVD with ridiculously long clips, unrealistically long, and this has worked. We later tried the same with realistic length clips and this completed in 11 minutes with no errors.
This was done on a GoPro 3, recording in 1080p at 30fps.

When we tried the same process with 1080p 60fps at unrealistic lengths we were unsuccessful - saying the same low memory error, and when continuing to attempt to burn, it said DVD.mpg couldn't be found.
Luckily we don't need to be using this setting, at the moment.

I really hope this will help you out.
If you would like more information just ask.

Mick Hardy
Thanks so much for keeping me updated Jordan. I've always suspected this to be a memory issue of some kind, possibly made worse with TandemVids running inside Vegas so Windows thinks all my memory is actually being used by Vegas. I have reproduced this issue without TandemVids so I think it is certainly a Vegas issue. I never really got to the bottom of it but the workaround has always resolved it for me.

Have you tried the workaround where you include the audio inside the video file so Vegas only needs to render one file?

None of the systems I've configured lately have shown this issue. I usually disable GPU acceleration. This setting causes crashes when running multiple instances so I turn it off. I wonder if this setting is causing the audio rendering crashes as well. This setting can be found under Options -> Preferences -> Video. Set GPU Acceleration to OFF and see if it helps.

Cheers. Mick.
Mick Hardy
I've never managed to reproduce this issue exactly as described although I can crash Vegas by rendering particular projects to AC3 multiple times in a loop. It usually requires about 50 iterations to crash.

If you have this issue, try installing the trial edition of Vegas 13 side by side with your current version or inside a virtual machine such as Oracle's VirtualBox . You can switch between Vegas versions within TandemVids using the "Sony Vegas App" field found under Tools | Options | Files. Restart TandemVids to complete the switch. If this fixes the problem, upgrade or buy Vegas 13 and move on.


Thanks for the reply, sorry for our slow return to you.

Throughout the season we have seen errors occurring on go pro 3's using the exact same settings, same footage standard and lengths, or at least close enough, but errors that are unexplainable to us.

The most common is during an edit Tandemvids will saying swoopwear has had a malfuction....and in the events log it's reporting "Invalid Media Object" ?

This morning I tried your one file solution, but I cannot even get pat the "Populating empty events" stage without Swoopware: Exception Logging saying that a malfunction has occurred.

We're pretty stuck at the moment as we need to push towards go pro as a standard but we are stuck in the dark ages with sony xc's.

Any help is appreciated.

<data>Swoopware.TandemVids.2011.1.5.0 Invalid media object.</data>
Mick Hardy
TandemVids and Vegas certainly support GoPros. Try the latest version of TandemVids. Your version is very old. Install straight over the top. All settings and templates will remain intact.

Mick Hardy
I had a similar issue recently when I offered remote support for a customer. After a little bit of investigation, it was revealed that despite saying nothing had changed, they had in fact updated from Windows 8 to 8.1.

Rendering crashes were regularly occurring and appeared to be random, intermittent and common across many different rendering engine templates, not purely the DVD and AC3 audio.

Turning off GPU Acceleration did make things slightly better but didn't fully rectify the issue. During the analysis, I discovered another setting inside the individual rendering engines within Vegas. This setting effectively overrides the GPU Acceleration setting and turns this feature back on. After customising the templates to turn this off, the issues were resolved. This lead me to try updating the video drivers.

I downloaded the latest Windows 8.1 video drivers for the Intel integrated GPU and everything was magically fixed. I turned GPU Acceleration back on in the global settings and in the individual rendering templates. Rendering was much faster and stopped crashing. The issue has been fully resolved and their system is 100% stable.

Try the settings in the screenshots below and see if they resolve the issue.
Mick Hardy attached the following image(s):
Mick Hardy
The post above is taken from another thread where random intermittent rendering crashes were occurring on a Windows 8.1 machine.

It's worth trying the suggestions given in that thread and seeing if they help the situation. I often work my way through issues like this when I logon to customer machines remotely. The steps I suggest in the thread linked below are detailed in screenshots but the exact procedure varies from system to system. Perseverance is the key. I'm pretty sure everyone resolves their issues eventually. I have several dropzones producing hundreds of videos per day without encountering these rendering issues.